Les emplacements des fichiers TrainController et TrainAnimator dans un ordinateur

Souvent se pose le probléeme pour les débutants ou bien ceux qui n’interviennent pas souvent dans les répertoires
de leur ordinateur et qui oublie ou sont placés les fichiers de RRTC.

Les exemples ci-dessous ont été pris sur un PC sous Windows 10 mais vous pouvez facilement transposer.
1- D’abord on retrouve des fichiers de données dans le répertoire « One Drive » dans le dossier « Documents »
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En ce qui me concerne j'ai créé des sous dossiers dans lesquels je range les données afin de m’y retrouver plus
facilement.

- v 'L > OneDrive - Personal > Documents > Railroad & Co » TrainController »

I Raiload&Co =T cheminement A Nom B
e I Accessoires

B Accessoires I Données de Locomotive
1 Accessoires étendus (signaux) B Gisinples 8 Démos
1 Accessory L Fichiers 20194 2021
I Fichiers Image 1 Fichiers 2022

I Fichiers Son I Locomotive Data
1 Fichiers YRF divers

1 Image Files

I Images locomotives BMP Fid::“

I Sound Files -

1 TrainAnimator

1 TrainProgrammer



Ensuite on retrouve des fichiers dans le répertoire « OneDrive » « Documents » et Railroad & Co qui sont les

fichiers de vos sessions de jeux.

J'archive ces sous dossiers par année pour ne pas avoir un écran avec plein de dates. Mais on pourrait aussi ne pas

les conserver, exemple ici I’'année 2022

NB : j’ai supprimé les dossiers de 2014 (et antérieurs) a 2018 concernant les V7 et V8, mais je les ai conservé dans un

disque dur externe avec toutes mes sauvegardes...

v Railroad & Co

Accessoires

Accessoires étendus (signaux)
Fichiers Image

Fichiers Son

Fichiers YRF divers

Images locomotives BMP

VW W VY Y Y Y

TrainAnimator

TrainController

<

Accessoires

Données de Locomotive
Exemples & Démos
Fichiers 2019 & 2021
Fichiers 2022

VOIW v v vy

Locomotive Data

* OneDrive - Personal > Documents * Railroad & Co * TrainController * Fichiers 2022

~
Nom

Gold IC & janvier 2022 9B 03
Gold JC 6 janvier 2022_9B 03.yrrg
D Gold JC 6 janvier 2022_9B 03.yrwg
Gold JC 8 janvier 2022 9B 03
Gold JC 8 janvier 2022_9B 03.yrrg
D Gold JC 8 janvier 2022 9B 03.yrwg

Gold JC 8 septembre 2022_9C 01
Gold JC 8 septembre 2022_9C 01.yrrg
D Gold JC 8 septembre 2022_9C 01.yrwg
Gold JC 10 févrierr 2022_9B 03

Gold JC 10 févrierr 2022 9B 03.yrrg
D Gold JC 10 févrierr 2022_8B 03.yrwg
Gold JC 12 avril 2022 9B 03

Gold JC 12 avril 2022_9B 03.yrrg

D Gold JC 12 avril 2022_9B 03.yrwg
Gold JC 14 avril 2022_9B 03

Gold JC 14 avril 2022_9B 03.yrrg

D Gold JC 14 avril 2022_9B 03.yrwg

Gold JC 14 avril 2022_9B 03_Backup_9.0B3

Statut

(CHONONONORONCRONONONCHONCIONONCONONC]

Modifié le

09/01/2022 18:48
09/01/2022 18:48
09/01/2022 18:48
15/01/2022 01:36
11/01/2022 23:28
15/01/2022 01:36

03/10/2022 16:45
03/10/2022 15:05
03/10/2022 16:45
08/03/2022 10:57
08/03/202210:57
08/03/2022 10:57
17/04/2022 11:56
17/04/2022 11:56
17/04/2022 11:56
18/04/2022 18:35
18/04/2022 18:35
18/04/2022 18:35
18/04/2022 18:35

Type
TrainController Go...
bak

Fichier YRWG
TrainController Go...
bak

Fichier YRWG

TrainController Go...
bak

Fichier YRWG
TrainController Go...
bak

Fichier YRWG
TrainController Go...
bak

Fichier YRWG
TrainController Go...
bak

Fichier YRWG

TrainController Go...

Ensuite dans le dossier « Accessoires » : vous allez y retrouver aussi les fichiers YRG (si vous avez créés des

accessoires étendus ?) comme par exemple les onze premiers signaux ci-dessous.

> Fichiers Son

>

>

>

3

>

Fichiers YRF divers
Images locomotives BMP
TrainAnimator
TrainController
Accessoires
Données de Locomotive
Exemples & Démos
Fichiers 2019 & 2021
Fichiers 2022

Locomotive Data

Sony

Téléchargements GigaTribe

Images

B CePC

> r Bibliothéques

Dans le dossier « données locomotives »

¥ w. Elements 2To (D)

wetransfer_video-sur-rocomotion_2022-03-22_1910

Nom

D Signal 2 feux Type Nain (SGL 100-1)
D Signal 3 feux Type A (SGL 220)

D Signal 4 + 2 feux type 3

D Signal 4 + 2 feux Type 3 (SGL 231-1)
D Signal 4 feux Type 3 (SGL 230)

D Signal 4 feux Type Disque (SGL 251)
D Signal 5 feux Type C (SGL 240)

D Signal 5 feux Type E (SGL 300)

D Signal 6 + 2 feux Type E (SGL 301-1)
D Signal 6 feux Type E (SGL 301)

D Signal 6 feux Type G (SGL 310)

[] SNCF B 4 FEUX

[] SNCF C 5 FEUX

[ sncFD

[) SNCF E 5 FEUX

[] SNCF F 6 FEUX

[] SNCF G 6 FEUX

D SNCF H 8 FEUX OLD

[] SNCF H 8 FEUX

Statut

PR RERRERRERRERERE

Modifié le Type

17/08/2018 1757 Fichier YRZ
17/08/2018 1758 Fichier YRZ
17/08/2018 1749 Fichier YRZ
17/08/2018 1758 Fichier YRZ
17/08/2018 1758 Fichier YRZ
17/08/2018 1759 Fichier YRZ
17/08/2018 1759 Fichier YRZ
17/08/2018 1759 Fichier YRZ
17/08/2018 1759 Fichier YRZ
17/08/2018 18:00 Fichier YRZ
17/08/2018 18:00 Fichier YRZ
16/10/2019 16:31 Fichier YRZ
16/10/2019 16:32 Fichier YRZ
16/10/2019 16:32 Fichier YRZ
16/10/2019 16:32 Fichier YRZ
16/10/2019 16:33 Fichier YRZ
16/10/2019 16:33 Fichier YRZ
16/10/2019 16:33 Fichier YRZ
16/10/2019 16:33 Fichier YRZ

: les fichiers « yra » créés dans TrainAnimator, dans le sous dossier

« standard » dont j’ai remplacé les sous dossiers « Cars#Wagen » & Locomotives#Lokomotiven par mes sous

dossiers avec des matériels Francais.



« v 4 I > OneDrive - Personal > Documents > Railroad & Co > TrainController > Données de Locomotive > ~ O
> I Fichiers Son A Nom " Statut Modifié le
> | Fichiers YRF divers B it o 20/09/2022 14:19
> 1 Images locomotives BMP I Autorails ) 29/09/2022 14:19
> | TrainAnimator I Diésels &) 29/09/2022 14:19
v | TrainController I Electriques (4] 29/09/2022 14:19
I Accessoires I Tracteurs O 29/09/2022 14:19
v | Données de Locomotive I Vapeurs & 29/09/2022 14:19
> 1 Automotrices l Voitures S 29/09/2022 14:20
> 1 Autorails W iagens & 29/09/2022 14:20
> 1 Diésels sous dossiers que j'ai créé pour remplacer ceux d'origine
5 B Bscticass aofin de m'y retrouver plus facilement
1 Tracteurs
I Vapeurs NB : ces dossiers sont également dens TrainAnimator
> L Voitures
> L Wagons

Par exemple ici les vapeurs

- ~ 4 | I * OneDrive - Personal * Documents > Railroad & Co * TrainController > Données de Locomotive > Vapeurs v

> L Accessoires étendus (signaux) o MNom Statut Modifié le Type
> W Rchiers Image 030 Boar o 03/05/2018 00:26 TrainAnimator File
> [ Fichiers Son 030 DRG O 22/01/2018 19:09 TrainAnimator File
> I Fichiers YRF divers 030T e 22/01/2018 19:10 TrainAnimator File
» L Images locomotives BMP 030 TU4 Soyez Vigilants O 22/01/2018 19:10 TrainAnimator File
s @ TrainAnimator 040 DB 55 e 22/01/2018 19:10 TrainAnimator File
« 7 TrainContraller 050 TB-7 L 22/01/2018 19:10 TrainAnimator File
Pt 130 TABR 74 Lo 22/01/2018 19:11 TrainAnimator File
) 130 TB 029 2 22/01/2018 19:11 TrainAnimator File

v | Données de Locomative .

_ 130 TB 717 s} 19/09/2017 11:29 TrainAnimator File
ot ieegiats = 140 BR DB 56 o 22/01/2018 19:11 TrainAnimator File
> I Autorails 141 P 102 Venissieux O 22/01/2018 19:12 TrainAnimator File
> I Diésels fichiers 141 TA 416 e 22/01/2018 19:13 TrainAnimator File
» L Hectnques W de 141 TA 501 Metz [&] 22/01/2018 19:13 TrainAnimator File
s 1 Tracteurs TrainAnimator 150 X 146 2 22/01/2018 19:37 TrainAnimator File
> 1 Vapeurs 150 Z 095 La 22/01/2018 19:14 TrainAnimator File
> 1 Voitures 230 B 029 e 19/09/2017 11:38 TrainAnimator File
N Wagons 231 E23 Chapelon Nord chocolat ] 22/01/2018 19:16 TrainAnimator File

i 231 E23 Pacific Noire S 22/01/2018 19:15 TrainAnimator File
» I Exemples & Démos - - g =
231 K72 Dijon ] 22/01/2018 19:16 TrainAnimator File
I Fichiers 2019 3 2021 . S §
’ R 231 K82 Calais e 22/01/2018 19:16 TrainAnimator File
> W Fichiers 2022 232 TC423 o 22/01/2018 19:17 TrainAnimator File
> I Locomative Data 241 PT Nevers O 22/01/2018 1917 TrainAnimator File
N Crnu s [ rnan neatieenn ~ 17417 N3 NAAT e M e el

Les images format « bmp » (1) qui ont servies a créer ces fichiers « yra » sont stockées a un autre endroit de mon
ordinateur dans mon dossier « Train ».

D’ailleurs j'avais créé les fichiers avec TrainAnimator en V8 et juste fait un copié/collé en V9 et idem pour la V10.
(1) Cest d’ailleurs les mémes images (en modifiant la taille) qui m’ont servies pour la centrale ECoS.

Comme vous pouvez le voir (sur I'image ci-dessous) plusieurs versions de TC peuvent cohabiter sur votre ordinateur,
on peut les renommer pour les retrouver plus facilement I'essentiel c’est de bien faire attention de ne pas utiliser le
méme nom.



2- Doncicion arrive dans le répertoire « Ce PC » celui dans lequel TC enregistre vos sessions de jeu par
exemple ci-dessous n’ayant pas fait de modifications dans la structure de TC mais juste fait des tests sur la
V10 ET je n’ai pas changé le nom lors des derniers enregistrements donc la date du 20 septembre est restée
dans le nom du fichier ce qui écrase tous les enregistrements depuis cette date jusqu’au 3 octobre ! donc si
vous souhaitez conserver un fichier précédent il faut changer le nom par exemple ici si j’avais remplacé le 20
septembre par le 3 octobre on verrait dessous une deuxieme série avec les 3 enregistrements

correspondants.
« v 4 > CePC > Documents > Railroad & Co > TrainController -ecm=——= cheminement v | D
A o~
» @ OneDrive - Personal Nom Statut  Modifié le
Gold JC 20 septembre 2022_10 A2 03/10/2022 18:22
v ®mCePC -
- Gold JC 20 septembre 2022_10 A2.yrrg 03/10/2022 16:44
> B
" 2 D Gold JC 20 septembre 2022_10 A2.yrwg 03/10/2022 18:22
v Documents 2&me réputm
Fichiers enregistrés en fin de session
> BS -
y Cy ¢'est ici que TC viendra chercher le dernier fichier utilise
lors de la prochaine session
v Railroad & Co
? Common Petite astuce : changer la date ou le nom en fin de session
3 TrainAnimator par exemple ici le 3 octobre on aurait put indiquer cette date
TrainController a la place du 20 septembre
Idem pour TrainAnimator
« v 1 & * CePC *» Documents * Railroad & Co * TrainAnimator > v | O
~ -~ Lo
> @ ke Rasond Nom Statut = Modifie le
Automotrices 02/10/2022 20:53
v ®mCePC
- I Autorails 02/10/2022 2053 O les retrouve
> ureau
: I Diésels 02/10/2022 2053 ~ Oussi dans TA
¥ B Poomcut: I Electriques 02/10/2022 2053 PFO9F arame XB6
> 8 SEomce Fichiers YRF divers accessoires 02/10/2022 20:53
> L Cyberlink | LocoTracteurs 02/10/2022 20:53
v | Railroad & Co L Vapeurs 02/10/2022 20:53
» L Common L Voitures 02/10/2022 20:53
5 VB Triaior I Wagons 02/10/2022 20:53
TrainController ici sont stockés les fichiers * yra “créés por TrainAnimator

3- Ensuite le répertoire Programme (x86) celui dans lequel TC s’installe et celui qui va vous permettre
d’installer les (dll) des fichiers « francisés ».

Ces derniers sont a téléchargeables sur le « One Drive » du forum RRTC (si vous étes membres de celui-ci) :
https://traincontroller.forum-actif.net/forum

Les exemples ci-dessous avec les deux versions qui sont présentes dans mon PC dont la V10 qui me sert pour les
tests.

Lorsque I'on a téléchargé le fichier Zip sur son ordinateur il faudra le décompresser :



d | B B P = | WinZip - Paquet Cadeau_V10A2_Gold_32.zip

Fichier Décompresser / Partager Edition Copie de sauvegarde Qutils Réglages Affichage Aide
Al Nom du dossier : E?q @ Tous les Fichiers 0‘

lasser| 1-cliquez *) Fichiers sélectionngs ~ Rechercher
Décompresser ¥ &

- 5
'mEmplacement :

Fichiers & décompresser

Décompresser

»
9 Type difié Taille  Ta..

ide_TC_V10_Gold.chm.

Fichier HTML compilé {r
& Paguet Cadeau_V10A2 Gold 32.pdf  Document Adobe Acrobat

Mettre 3 jour

xR B B *

Email Média Messagerie Que Compresser Obtenir plus de modules

Social Instantanée Partager~ et partager

Partager

Regr.. Chemin
09/10/2022 11...  1082.. 2% 106..
09/10/2022 11... 1973.. 3% 191..

complémentaires

Modules complémentaires Express

A copier dans le fichier

] railres32_V10A2_Gold_fr.dll Extension de I'application 30/09/2022 19... 1851.. 87.. 239. de miwomollgp
Signaux_fr.yrf Fichier YRF 28/02/201011... 35444 95. 1689
A Nom ® Modifié le Type Taille

@ Paquet Cadeau V10A2 Gold 32  10/10/2022 08:50  Fichier WinZip 3s60ko <= Fichier Zippé
@ Aide TC_V10_Gold.chm 09/10/2022 11:32  Fichier HTML compilé 1058 Ko

Paquet Cadeau VI0A2 Gold 32  09/10/2022 11:32  Document Adobe ... 193 Ko DéZi P Pé

railres32 V10A2 Gold_fr.dil 30/09/2022 19:26  Extension de l'app... 18 080 Ko

D Signaux_fr.yrf 28/02/2010 10:08 Fichier YRF 35 Ko

Et ensuite aller le copier dans le répertoire de TrainController et pour cela on va dans les répertoires de
Windows (C :) ensuite Programmes (x86) et Railroad & Co.V(la version qui vous intéresse).

Les mémes manipulations seront aussi valable pour TrainAnimator, d’ailleurs je télécharge les deux dossiers Zip

dans la foulée et mets toutes les dll francisées en méme temps.

& = v 4 |l > CePC > Windows (C) > Programmes (x86) > <—1 cheminement + | O

v & Windows () <=t= ~ Nom
> s : Mi
Mi

> $
; I Mi
L ph
£ Pi

? ProgramData

> I Programmes G

v l Programmes (x86)
> B A

. W a

L Railroad & CoV9 C1
L Railroad & CoNV10 A2
iR

Madifié le

09/04/2020 14:47
08/02/2021 18:28
13/11/2020 13:53
09/04/2020 15:01
12/11/2020 19:42
08/09/2022 17:55
02/10/2022 20:53

Si on clique sur I'un des deux dossiers par exemple TCV9C1 on visualise les fichiers suivants

Type
Dossier de fichiers

Dossier de fichiers
Dossier de fichiers
Dossier de fichiers
Dossier de fichiers
Dossier de fichiers

Dossier de fichiers



> B Pro’-m »xB6 A Nom Modifié le Type Taille

> B examples 08/03/202119:47 Dossier de fichiers
>n B TrainAnimator 08/03/2021 19:47 Dossier de fichiers

>R @ common 22/01/2008 18:10 Microsoft Edge HT.. 4Ko

> B @ Doc Francisation 04/07/2022 09:58 Document Adobe ... 216 Ko

> B B 1og0ta 09/01/2022 16:39 Fichier BMP 545 Ko

> @ B 1ogo1ce 09/01/2022 16:39 Fichier BMP 545 Ko

> . # railanm32 03/07/2022 12:52 Fichier HTML com... 92 Ko

o m“ m &j” w 60” railanm32 03/07/2022 12:52 Application 5844 Ko

[ Railanm32.yrw 08/09/2022 1839 Fichier YRW 3Ko

& railanm32_ VICI(EN) <= 31/01/2021 11:41 Fichier HTML com... 92 Ko

> I canple: railanmres32.dil 03/07/2022 1251 Extensionde l'app.. 12996 Ko

v [ TrainAnimator railanmres32_ VOCI(EN)Il <3=2 03/07/2022 12:51 Extension de l'app.. 12984 Ko

> [ Standard &) Railco32 06/12/2013 16:29 Document de feuil... 8Ko

v [ Railroad & CoN10 A2 railctri32.dil 03/07/2022 12:53 Extension de 'app... 1368 Ko

s B examples raildii32d.dil 03/07/2022 12:53 Extension de I'app... 6336 Ko

v B TrsinAnimator railhandres32.dil 03/07/2022 1255 Extension de I'app.. 14 104 Ko

raillent32.dil 03/07/2022 1252 Extension de I'app... 100 Ko

. ; - fichiers & extensions [ RaillLLstp 03/07/2022 1305 Fichier STP 6Ko

d' applications railpres32.dil 05/07/2022 1136 Extension de fapp.. 12456 Ko

> & railprg32 09/10/2017 13:22 Fichier HTML com... 186 Ko

> 8 railres32.dll 04/07/2022 15:48 Extension de l'app.. 17 220 Ko

) railres32 VOCIEN)AIl <= 03/07/2022 12:52 Extensionde lapp.. 17172 Ko

& RAILROAD 08/09/2022 18:38 Paramétres de con... 1Ko

[0 Railroad.stp 03/07/2022 1305 Fichier STP 1Ko

& railtcg 28/02/2021 16:49 Fichier HTML com.. 776 Ko

& railtcg VICI(EN) <=2 03/07/2022 12:53 Fichier HTML com... 710 Ko

(& railtcea2 03/07/2022 1255 Application 9884 Ko

# railtipta 03/07/2022 12:52 Fichier HTML com... 14 Ko

# railtipteg 06/03/2021 13:15 Fichier HTML comn... 16 Ko

les fichiers avec flRches rouges ont # railtiptcg VICI(EN) <= 03/07/2022 12:53 Fichier HTML com... 16 Ko

éré mm por les dil f ial & raittiptp 04/12/2019 14:44 Fichier HTML com... 15 Ko

[ signaus_fryrf 28/02/2010 10:08 Fichier YRF 35 Ko

pour TC&TA (& Train Animator setup V9_C1 08/09/2022 1837 Application 6754 Ko

v uninstall 03/07/2022 13:05 Application 156 Ko

Les petites fleches rouges indiquent les fichiers « francisés pour TrainController & TrainAnimator

ATTENTION comme j’utilise une version Gold les fichiers Silver et Bronze ne sont pas présents dans mon exemple il

faut bien lire le document texte (maintenant en format pdf) qui est joints dans les « paquets cadeaux » (nom utilisé
pour signifier que des bénévoles passent beaucoup de temps pour nous offrir ces fichiers).

En principe les paquets cadeaux sont maintenant organisés par versions de TC : Bronze, Silver et Gold il n’y a plus
donc la possibilité de se tromper.

Les fichiers dll de TrainAnimator sont accessibles sur le site de Gérard (alias labcane77) https://labcane77.monsite-
orange.fr/page-5d44519c2f814.html

Pour la version V10 c’est le méme processus

https://papybricolo.over-blog.com/




